• 新浪微博:
  • 微信 :
按键精灵电脑版
立即下载

软件版本:2014.05
软件大小:21.6M
更新时间:07-04

按键精灵安卓版
立即下载

软件版本:3.3.0
软件大小:62.5M
更新时间:5-24

按键精灵iOS版
立即下载

软件版本:1.3.3
软件大小:29.2M
更新时间:06-14

按键精灵Mac版
立即下载

软件版本:1.1.0
软件大小:12.3M
更新时间:12-29

快捷导航

登录 后使用快捷导航
没有帐号? 注册

登录 注册
发新话题 回复该主题

[分享脚本] 帮助您实现群控安卓小精灵,E语言+按键群通讯例子 [复制链接]

1#
在接触安装按键精灵有一段时间了~现在手机应用和游戏热潮,各类脚本是创造收益的主要来源,很多时候你想能够让自己的服务器掌控所有脚本用户的使用情况,甚至是把违规脚本用户关小黑屋(这个具体能干什么你懂的,啥用来脚本收费?我没说~是你说的。呵呵),不多废话,至于能干什么请 看下面的介绍:
一、安卓按键小精灵与易语言服务端的通讯。
很多小伙伴一直在纠结安卓按键小精灵只有一个GET和POST功能,没有像易语言一样的客户端、服务端的功能,怎么办? 这个问题我只能说你的学习不够,其实GET和POST 是直接可以与易语言的服务器组件直接通讯的。那么下面我教大家怎么做。

通讯传输有两种类型,分别是文本字符串和图片字节集两种类型
(1)文本传输,安卓小精灵通过自带的GET或POST命令直接发送字符串给易语言服务器端,易语言的服务器端和安卓按键精灵的代码可以这样写:
========安卓按键精灵发送文本代码==========
DIM 服务器返回
服务器返回 = URL.Get("http://192.168.1.1:8000/YHDLID=123456&YHDLMM=123&")
If 服务器返回 = "OK" Then
TracePrint "提交到服务器成功"
End If
========安卓按键精灵发送文本代码==========
解释:括号里的"http://192.168.1.1:8000/YHDL=ID123456&"这串我给小白解释一下,http://192.168.1.1:8000里的IP地址是你E语言服务端的IP,:8000是服务端口。后面的YHDL=ID123456&YHDLMM=123&
是你自己自定义想发什么就发什么,我这里写的这个是 用户登陆ID=123456 的用户登陆密码是123,告诉我的服务端ID123456的用户请求登陆使用脚本。这个是你自己根据你自己的实际需求自己遍想怎么写都行,只要自己记得啥意思就行。


===========易语言代码============
.版本 2
.支持库 spec

.子程序 _服务器1_数据到达
.局部变量 客户, 文本型
客户 = 服务器1.取回客户 ()
调试输出 (客户)
调试输出 (到文本 (服务器1.取回数据 ()))
=============易语言代码============
通过上面的代码接收到安卓按键精灵发来的登陆数据是这样的
* “GET /YHDLID=123456&YHDLMM=123& HTTP/1.1
User-Agent: Dalvik/2.1.0 (Linux; U; Android 5.1.1; m3 note Build/LMY48Z)
Host: 192.168.1.101:8081
Connection: Keep-Alive
Accept-Encoding: gzip

上面的就是易语言收到的信息,那么我们就可以取出“GET /YHDL=ID123456& HTTP/1.1部分里的ID是123456密码是123,那么我们拿到数据库里查询一下有没有这个用户,是否给这个用户运行脚本,如果查询到了就返回数据。
这里注意返回的数据依然需要添加协议头。是不是很简单?

======E语言服务端返回数据给小精灵代码==========
.版本 2
.支持库 iconv

.子程序 编译文本数据包, 文本型
.参数 发送内容, 文本型
.局部变量 txt, 文本型

发送内容 = 到文本 (编码转换 (到字节集 (发送内容), #编码_GB2312, #编码_UTF_8, ))
txt = 子文本替换 (#文本协议头, “#长度”, 到文本 (取文本长度 (发送内容)), , , 真) + 发送内容
返回 (txt)
======E语言服务端返回数据给小精灵代码========
上面代码中子文本替换里的 #文本协议头 内容如下:
HTTP/1.1 200 OK
Connection: close
Content-Length: #长度
把这个内容放到常量里,与小精灵的通讯部分就写完了剩下的就是写你想控制小精灵干啥了。

还有一个需要注意的问题,易语言返回给按键小精灵的文本数据需要将GB2312编码转为UTF-8编码再发送,否则小精灵收到的内容就是?????呵呵。
如果有什么疑问的可以加Q群724287789一起交流学习。
明天分享一下如何总控实时修改虚拟定位全自动添加微信或陌陌好友的按键精灵脚本制作方法。

写到这里可能很多小伙伴就会说,就只能写登陆合用户管理么?错了,刚才我就说你想写啥都行,给你点思路吧:
1、你可以把关键性的坐标点保存到服务器,只有合法用户登陆后从服务器索取坐标,你的脚本才能正常运行。
2、你可以通过易语言再与WEB交互远程网页管理。
3、你也可以创造托管式的脚本,用户只用看数据就行,所有的运行行为全部托管给你来运作。
4、你可以远程操控管理云手机,也就是说,云手机上装的小精灵也就是个壳,实际所有的操作指令都是由你的服务器索取到小精灵的截图判断后发送指令给小精灵执行。最终实现团控。


版主求加精!!!

最后编辑shunli096 最后编辑于 2018-02-28 17:41:27
2#

方法不错,赞一个

3#

支持支持支持

发新话题 回复该主题